Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Cannot Upload Images to Ecwid Products via Wix Editor
Incident Report for Ecwid
Resolved
IMPORTANT: Incident only affects merchants, who created Ecwid accounts through Wix

Glad to report, that currently you can again upload gallery images or main images to products, if you are managing your Ecwid store via Wix Editor. The problem has been resolved.

Thank you for your patience.
Posted Apr 16, 2018 - 17:25 UTC
Identified
IMPORTANT: Incident only affects merchants, who created Ecwid accounts through Wix

We are sorry to inform you, that currently you cannot upload gallery images or main images to products, if you are managing your Ecwid store via Wix Editor. The problem has been identified, and our engineers are working with Wix to resolve the issue.

None of your existing data (images, gallery images or anything else) is in danger — all your existing images are loading fine for your website visitors.

We also found a workaround for this problem: if you need to upload your images now, please, log in to your Control Panel directly at https://my.ecwid.com, and you will be able to flawlessly work with your catalog.

We will be posting updates here. Thank you for understanding.
Posted Apr 16, 2018 - 13:06 UTC