Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid service maintenance
Incident Report for Ecwid
Resolved
The maintenance is over. All Ecwid services are up and running.
Posted Jun 20, 2016 - 15:36 UTC
Monitoring
We’re having a scheduled maintenance of orders search service on June 20, from 15:30 PM to 15:40 PM UTC

During this time the following services will be partially available:
- Searching for products
- Ecwid Mobile application

We expect the maintenance to be over on June 20, 15:40 PM UTC . All your data and store settings will be kept intact and our engineers will do their best to perform it as smooth as possible.
Posted Jun 20, 2016 - 15:25 UTC