Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Product images can not be uploaded via Wix admin panel
Incident Report for Ecwid
Resolved
Our developers restored the service, and product images can be uploaded via Wix admin panel properly.

Please, accept our apologies for the trouble. Our engineers will do their best to make sure this doesn't happen again.
Posted Sep 28, 2016 - 13:37 UTC
Investigating
The status concerns those Ecwid store owners, who upload product images via their control panels through our Wix app.

At the moment product images can not be uploaded via Wix admin panels. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 30 minutes.

As a temporary workaround, you can upload product images in your control panel at https://my.ecwid.com directly. Just follow these easy steps:

1. Go to https://my.ecwid.com/cp/.
2. Use your email address and password to access the control panel.

If you forgot your password, you can easily reset it using the "Forgot your password?" link below the login form at https://my.ecwid.com. Screenshot: http://take.ms/4a3uV

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Sep 28, 2016 - 12:36 UTC