Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

"Billing and plans" page temporarily unavailable in Ecwid control panels.
Incident Report for Ecwid
Resolved
We've restored the service, and all "Billing and plans" pages in control panels are now up and running normally.
So, viewing, creating or managing subscriptions is available.

All existing subscriptions remained safe, and so did store data.

Please, accept our apologies for the trouble. Our engineers will do their best to make sure this doesn't happen again.
Posted Apr 22, 2016 - 15:28 UTC
Investigating
We're having difficulties with one of our servers, and "Billing and plans" pages in Control panels are not loading at the moment.
Because of it it's temporarily not possible to view next charge date, payment history, switch between plans and subscribe to paid apps (free apps are still available).

We're really sorry about this incident, and our team is already working on a fix.

All your subscriptions and store data is safe, and will be preserved.
Posted Apr 22, 2016 - 15:11 UTC