Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Ecwid Control Panels and storefronts may not load for 14% of users
Incident Report for Ecwid
Resolved
Our Engineers have fixed the issue with the affected servers and all the Ecwid Control Panels and Storefronts are loading as normal now.

Please accept our apologies for this issue. All your data are safe and intact. All the Ecwid stores continue functioning as usual.
Posted Aug 11, 2018 - 06:01 UTC
Identified
We are experiencing technical issues with some of our servers and some of the Ecwid Control Panels and Storefront may not load or load slowly. It may affect only 14% of the users. Our Engineering team is already aware and they are working on a fix now.

All your data will be kept intact and safe. Please, accept our apologies for this downtime. We will inform you of the progress here.
Posted Aug 11, 2018 - 05:59 UTC
This incident affected: Storefront and Admin.