Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Scheduled maintenance of Ecwid databases
Incident Report for Ecwid
Resolved
The maintenance is over. All Ecwid services are up and running.
Posted Apr 29, 2015 - 14:59 UTC
Investigating
We’re having a scheduled maintenance of our services on April 29, from 14:47 AM to 15:00 AM UTC. We expect the whole system to be restarted and inaccessible within 2 (two) minutes: all of Ecwid storefronts and control panels may not be open.

We apologize for this possible downtime. Our specialists will be monitoring the system. All data including products, orders, stores settings will be kept safe and intact. We will be posting updates here.
Posted Apr 29, 2015 - 14:45 UTC