Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Problem with subscription
Incident Report for Ecwid
Resolved
We have restored the service, all Ecwid customers are now able to update subscriptions. All data (products, orders, store settings etc) is safe.

We’re sorry for the trouble. Please, accept our apologies for this downtime.
Posted May 29, 2016 - 08:19 UTC
Investigating
At the moment Ecwid customers may be experiencing issues with subscribing to the paid plans and updating the subscription. The billing page in the control panel is also not opening. Our development team has found the source of this issue and is in the process of restoring the service. All Ecwid storefronts and control panels are up and running, the issue affects only the ability to update subscription.

Existing subscriptions are not affected. If you are subscribed to the paid plan, your subscription is intact and the paid features are still available.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted May 29, 2016 - 08:02 UTC