Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

"Billing and plans" page temporarily unavailable in Ecwid control panels
Incident Report for Ecwid
Resolved
This incident has been resolved.
Posted Sep 14, 2017 - 04:04 UTC
Monitoring
Our monitoring system says the problem with "Billing and Plans" page has been fully resolved for everyone: all Ecwid users can manage their Ecwid subscriptions normally.

We sincerely apologize for any trouble caused by this downtime! Mind that all your store data, products, and settings are safe and intact and were not affected by the issue.
Posted Sep 14, 2017 - 03:28 UTC
Identified
Our engineers have detected the root of the problem with the unavailable "Billing and Plans" page and applied a fix. The page works normally in most Ecwid accounts now: users can switch between plans, stop subscription and upgrade their stores. We continue applying the fix for the rest of the affected Ecwid accounts. Further updates will be posted here.
Posted Sep 14, 2017 - 03:19 UTC
Investigating
We're having difficulties with one of our services which are causing that the "Billing and plans" page in the Ecwid control panels is not loading at the moment.

Because of it, it's temporarily not possible to view the next charge date, payment history, to switch between plans and subscribe to paid apps (free apps are still available) for some users.

We're really sorry about this incident, and our team is already working on a fix.

All your subscriptions and store data is safe and will be preserved. And we will keep post updates here.
Posted Sep 14, 2017 - 02:52 UTC