Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

The storefronts might be inaccessible for users from UK
Incident Report for Ecwid
Resolved
The issue with Amazon Cloudfront has now been resolved by Amazon for the users of British Telecom in UK.

The service is operating normally, so Ecwid is up and running as well. All your data is safe and intact.

Please accept our apologies for this issue.
Posted Aug 24, 2015 - 17:29 UTC
Update
Amazon provided an update that the incident is limited to the users of British Telecom ISP in the UK. Amazon and British Telecom teams keep working on resolving the issue. According to Amazon, there's a workaround allowing Ecwid users to access their Ecwid Control Panels (the storefronts will still be inaccessible for customers) - the DNS resolvers have to be changed to public ones like Google 8.8.8.8 or 8.8.4.4 . There's an instruction here: https://developers.google.com/speed/public-dns/docs/using?hl=en

We will keep monitoring the issue and will be posting updates here. You can also see the Amazon Cloudfront status on this page: http://status.aws.amazon.com/

Thank you very much for your patience.
Posted Aug 24, 2015 - 14:25 UTC
Monitoring
Amazon confirmed that users of only one ISP (Internet Service Provider) in the UK are unable to connect to Amazon CloudFront. That is the reason why some Ecwid storefronts and control panels being opened from UK are inaccessible right now. Amazon team is currently working on resolving the issue. You can also watch the status here: http://status.aws.amazon.com/
Posted Aug 24, 2015 - 13:36 UTC
Investigating
Ecwid CDN provider Amazon Cloudfront is having troubles with their servers.

The storefronts might be inaccessible for users from UK. At the moment our development team is investigating the issue. Amazon team is actively working on the recovery process. You can also check their status here: http://status.aws.amazon.com/

All your data will be kept intact and safe. Please, accept our apologies for these troubles. We will be publishing updates here.
Posted Aug 24, 2015 - 12:17 UTC