Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Some Ecwid Control Panels cannot be accessed via WIX admin panel
Incident Report for Ecwid
Resolved
We are glad to inform you, that we have fixed the issue with Ecwid Control Panel access from inside WIX admin area.

Our development team has tackled the problem, and the service is fully restored.

Thank you.
Posted Nov 20, 2017 - 19:08 UTC
Identified
At the moment Ecwid Control Panels cannot be accessed via WIX admin panel. The issue only affects accounts, that were created via WIX site builder, it does not affect direct accounts. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is about two hours. Please, know, that all storefronts are 100% available, and all your data will be kept intact.

But there is a workaround. You access your Control Panel directly at https://my.ecwid.com.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Nov 20, 2017 - 17:15 UTC