Ecwid status

We try to keep running at full speed, but if things get weird we'll update this page to keep you in the loop.
Having trouble? Email us at support@ecwid.com

Possible Sporadic Issues with Ecwid Availability
Incident Report for Ecwid
Resolved
The internet connection between the US and Europe has been restored.

All Ecwid stores and Control Panels are up and running.
All the data including products, orders and stores settings is intact.
Posted Jun 20, 2016 - 15:43 UTC
Monitoring
-
Posted Jun 20, 2016 - 13:32 UTC
Investigating
As we know at the moment there can be sporadic global issues with Internet connection all over the world as there is some trouble with TeliaSonera's network, that has transatlantic cables connecting up Europe and the US or with Amazon servers that provide power to a large part of the internet (according to Independent.co.uk)

There can be sporadic problems with opening your Ecwid Stores and Ecwid Control Panels. If you face this issue, try to open the site using mobile Internet connection (e.g. 3G).

We are monitoring the situation.

Please note that all data including products, orders, stores settings will be kept safe and intact.

We will be posting updates here.
Posted Jun 20, 2016 - 13:02 UTC